rFlickr And Rails 2.0

Any of you that followed my tutorial on setting up rFlickr and have subsequently upgraded to Ruby on Rails 2.0 may have noticed some server errors on your photo pages, this is due to the fact that a single line of code in rFlickr does not work correctly with Rails 2.0.

Line 644 of ‘lib/base.rb’ had to be modified from:

to:

Hope this gets you back on your feet, so to speak. Check back soon.

Update: You may also want to install the updated version of ‘actionwebservice’ because it is no longer bundled with the Rails distribution. Other people have reported rFlickr not working because of a lack of this gem, however, the lack of this gem didn’t affect my setup at all.